The Past Week... [UPDATED: 1/2 1:00 AM] - TeamUSCellular

Jump to content






Photo
- - - - -

The Past Week... [UPDATED: 1/2 1:00 AM]

Posted by snodrog742 , in US Cellular News and Rumors 30 December 2012 · 359 views

The Past Week... [UPDATED: 1/2 1:00 AM] You know those days that you just want to go back to bed? Yea, we all have them. How about those WEEKS!? I think you can safely say I've had one of those so let's get a little light on the subject.

Monday, Dec. 24:
IP.Chat (little Chat button at top) goes to an error that our license has expired. Odd, my records show valid license until June 2013. So, I reinstall it thinking they might've updated code and such - no luck. At the same time, I receive a message that the Facebook chat thingy has also expired.... again, odd, my records show I have until the 25th. Whatever, I was getting full version for site anyways so I proceed to do that. Somebody should've sat in my face screaming "DON'T DO IT!!!"

Well, purchased it, cool no big deal. Well, I unpacked the zip file, saw a folders inside a folder and went "oh, ODD, usually it says "Upload" so you know exactly which ones to upload." Well, I went to the multiple folders and started uploading rather than the one single large folder - no bueno. Essentially, it overwrote key admin directories and such. Okay, no biggie, we have a backup. :)

Message our host and he starts extracting the backup but this is a good 3 hour process and could be longer. :( He says it's in good hands and just get some sleep since tomorrow's Christmas.

Tuesday, December 25:
I wake up at 10 AM to a message that the backup didn't work but also that none of my logins will work. The core server was completely wiped, meaning our site plus at least 2 more I know the host has. Server company has started entire restore but that could take 12+ hours due to multiple sites now.

(Where's that eggnog??)

Oh, yeah, timeout here for an hour while I go open presents!

Ok, time in. While I was opening presents I came up with the idea of just picking up our old host, HostGator, for the time being just to get us through. Cool.... not. As I'm sure most of you saw the majority of the week, "Server currently under maintenance." Yea, no.... that was us blowing up resources with so many connecting at once! So I commend you all there. They removed our restriction twice but we still just kept hitting it within hours. Too late that night to do anything as I thought we would've been good since we were there before but guess not.

Wednesday, December 26:
Wake up to account still blocked due to resources. Come onnn, couldn't you have been forgiving HostGator?? So, off to hunt for a server. Settled on 1and1.com as many friends recommended them as well as jokersax awhile ago. Well, any server is at least 1+ hour set up and then get you login credentials and then however long it takes you to upload files. Got login about mid-afternoon and started uploads right away, BUT (yea, who saw that coming?), I noticed my upload speeds were nowhere near what they should be. Like, my connection maxed is 360 KB/s upload constant and i was getting 80 KB/s to them. I repeat, COME ONNNNNNNN. Call them up - nothing on their end, send diagnostics, etc. Uhhh, no. I've had plenty other places and THIS IS THE ONLY ONE HAVING ISSUES! Off to find another server, weeeee! Pick up KnownHost VPS before heading to bed again to wait for login.

Thursday, December 27:
Woke up to logins, created cPanel, email, directories needed to at least start uploads and set off again WITH correct speeds this time... :) Had a few issues getting links to work right and was going to get everything uploaded just right this time not just front page. A few support tickets later, a few friendly site owners at IPS, a lot of cussing, a lot of fiddling, and I finally had it functioning on an IP address. Gave it a night to upload basic necessities and hit a few roadblocks Friday...

Friday, December 28:
A few modifications wouldn't install so had to remove, reupload, reinstall for 4-5 of them. Not all of them are back including Rewards but I have it all backed up. This was when I released the IP address and started forwarding any teamuscellular.com traffic to the IP address exclusively. Tweaked a few cookie issues so that people could stay logged in (again, me fiddling because the instructions were wrong) and most the traffic was returning. Good thing, because this literally was 30 minutes before my family started arriving. Left the Downloads system restoring while I took a much needed time off to play games with my family until 2 AM.

Saturday, December 29:
Up at 10 AM (woken by children :() and quickly check to make sure everything is still restoring. All good, off to seize the day! Midday I got a break and quietly switched the domain back active so most should have been able to use it once again. I will be switching TapaTalk back to the domain as well so if that stops working please remove the forum and search again.

Throughout the whole ordeal I definitely learned a lot. I know we will always have 2 SERVERS now as shared hosting will not fit us ever again. The support has been incredible. Even if the site was up for 10 minutes there was a constant 50 people active on the site. I swear you all wore out that refresh button. Anyways, thank you and sorry such a long recap!

Sunday, December 30th:
Everything actually ran pretty well from VPS box for almost 24 hours.

Monday, December 31st:
VPS box started freezing. Storage became critical due to temporary files not deleting correctly. Site crashed repeatedly. Purchased dedicated server as I still hadn't heard from original host. Issues getting it set up so desperately messaged original host and he pushed quickly to get us back on his server successfully but all backups we had on server were corrupted which would've made restore faster. No worries - I have local backup, however, pictures will be missing and will just need replaced as I've uploaded all the pictures/thumbnails I have. My local backup was around the 9th, hosts backup was the 14th but was corrupted. Obviously the 9th to the 25th had a lot of pictures/thumbnails added but I just don't have them. Posts and downloads were the priority and they all seem mostly intact. Report something you see broken and offer an alternative if possible and I'll try to fix the original. :)

Tuesday, January 1st:
Still up and good. Waiting for domain to resolve correctly on mobile devices. Computers see the site correctly but mobile devices still do not. Not sure how long that will take. http://199.193.117.243/~nodrog/Forum works as well as Tapatalk is set up to that currently. Bad part - guests and bots are not tracking correctly so stats are pretty low. Still restoring downloads as well. 112 GB + my 3 Mb/s connection = will take awhile. Fixing little things as I see them as well but will just take me time. Give me a few days and if still see something major PLEASE shoot me a PM and I'll get it fixed ASAP. Again, thanks for the patience and continued support.

  • TokenBlackGuy likes this



Photo
HikingMoose
Dec 30 2012 12:34 PM

Thanks for all the work Snod.  It is appreciated, and awesome to have the site back!

tl;dr

 

jk

 

 

Boy, I've been there before.  Not for a while though.  Hopefully, its all in the rear view mirror and you've learned a few things and gained some experience.  War wounds never completely heal though.

Thanks for all your hard work Adam.  I'm glad it didn't appear to interfere with family time at Christmas.

I am so glad that I don't run sites any more...... But you did good in trying to keep it up as long as you could. Just one question...... You have any hair left on your head after all that?? LOL!

I am so glad that I don't run sites any more...... But you did good in trying to keep it up as long as you could. Just one question...... You have any hair left on your head after all that? ??? LOL!

Too much actually.  Need a haircut =/

Thanks for the update.

Photo
TeamAndroid
Jan 05 2013 03:19 AM

Aw man seems like you went through Hell and back. Glad you're steadily fixing things. Good luck on the rest(=


Trackbacks for this entry [ Trackback URL ]

There are no Trackbacks for this entry

Recent Comments

0 user(s) viewing

0 members, 0 guests, 0 anonymous users


1 2