Recommended Posts

well, the problem is my flash counter is 30+, and if i do a warranty exchange they should/will look at that, and i believe I will then have to pay for the replacement. If that becomes the case, I'll just run it over and pay $100 for a new one. lol.

Share this post


Link to post
Share on other sites
well, the problem is my flash counter is 30+, and if i do a warranty exchange they should/will look at that, and i believe I will then have to pay for the replacement. If that becomes the case, I'll just run it over and pay $100 for a new one. lol.
i did what TG mentioned. Flashed an ICS rom and use triangle away to reset the counter. Then used odin stock files. The store didnt check the counter but never know if they will check it when i send it in. Worked like a charm tho. Reset it with no problem

Sent from my SCH-R760 using Tapatalk

Share this post


Link to post
Share on other sites

Well, son of a.... That works. I'd seen that app previously, but it was risky and at the time barely tested. But it works great! Maybe I'll odin stock and take this thing back in to them!

Share this post


Link to post
Share on other sites

Well, son of a.... That works. I'd seen that app previously, but it was risky and at the time barely tested. But it works great! Maybe I'll odin stock and take this thing back in to them!

haha yeah man i was really being reckless when trying that since its not offically supported. but i saw people with e4gt using it so i decided to haha:P

Share this post


Link to post
Share on other sites

Well, son of a.... That works. I'd seen that app previously, but it was risky and at the time barely tested. But it works great! Maybe I'll odin stock and take this thing back in to them!

haha yeah man i was really being reckless when trying that since its not offically supported. but i saw people with e4gt using it so i decided to haha:P

Hey, it worked good. Good enough to convince the people at USCC to give me another one! My new one oughta be here by friday.

Share this post


Link to post
Share on other sites

Well, son of a.... That works. I'd seen that app previously, but it was risky and at the time barely tested. But it works great! Maybe I'll odin stock and take this thing back in to them!

haha yeah man i was really being reckless when trying that since its not offically supported. but i saw people with e4gt using it so i decided to haha:P

Hey, it worked good. Good enough to convince the people at USCC to give me another one! My new one oughta be here by friday.

If you took it in today, you might have it tomorrow! I took mine in yesterday and they told me a day or two, it came today! Very quick!

Share this post


Link to post
Share on other sites

To bad Im outside my 30 days or id go get a new one too.

no no, it's a warranty claim after 30 days. I'm at almost 2 months, so now it's a warranty replacement. They overnight you a replacement phone, you take it into the store and have it activated, and then you ship back your old one. You have to keep your battery cover and battery, because the new one is ONLY the phone itself. You have to agree to pay charges if they check it out and determine it's non-warranty (like water damage, physical damage, etc), it could cost between $25 and $150. I did the same thing with my mesmerize, when it had the phantom softkeys I odined back to stock and they replaced it, like over a year after i got it.

EDIT: oh, and unless you actually broke something (not software), and it appears to never have had custom firmware, you're pretty much guaranteed a free replacement.

EDIT 2: FYI, I went in and complained that my speakerphone wasnt working. Said I wasnt sure how long it'd been like that, blah blah blah... they took my phone in the back for a few minutes (I assume they tested it and/or checked the firmware) and then called their "tech support", who confirms the issue and then tells you the conditions and ships you a new one.

Edited by bru_1

Share this post


Link to post
Share on other sites

SPEAKERPHONE FIX!

After a couple hours of research, I've found the solution to the speakerphone issue. So sorry to all the people who already returned your phones. It's actually a very easy fix.

The main thread that made the most sense but also a bit more risk was found here: http://forum.xda-dev...d.php?t=1226074

I actually got the help of sfhub and tried his approach but it did not fix the speakerphone issue. Instead I went back to this thread and only did the first part.

To be safe: In CM9, or at least rooted FB14 kernel, I would copy the /EFS directory to external SD card. I'd also get your MSL, MEID, ESN information saved. I learned from sfhub you can do this by going into terminal emulator and typing getprop. You should get the MSL from one of the lines in the getprop output. The other info would be on the sticker on your packaging box also. You shouldn't need any of this information to do this fix but it's good to have it in case.

Steps:

  • - Odin back to stock ROM.
  • - Odin again with 'phone EFS clear' CHECKED and put the FB14 modem.bin in the PHONE section.
  • - On reboot, you'll need to do a *228 to activate.
  • - Another reboot and "profit" :P

Speakerphone works during calls again. Also found that mic works again with bluetooth headset.

YMMV

Edited by durango99

Share this post


Link to post
Share on other sites

SPEAKERPHONE FIX!

After a couple hours of research, I've found the solution to the speakerphone issue. So sorry to all the people who already returned your phones. It's actually a very easy fix.

The main thread that made the most sense but also a bit more risk was found here: http://forum.xda-dev...d.php?t=1226074

I actually got the help of sfhub and tried his approach but it did not fix the speakerphone issue. Instead I went back to this thread and only did the first part.

To be safe: In CM9, or at least rooted FB14 kernel, I would copy the /EFS directory to external SD card. I'd also get your MSL, MEID, ESN information saved. I learned from sfhub you can do this by going into terminal emulator and typing getprop. You should get the MSL from one of the lines in the getprop output. The other info would be on the sticker on your packaging box also. You shouldn't need any of this information to do this fix but it's good to have it in case.

Steps:

  • - Odin back to stock ROM.
  • - Odin again with 'phone EFS clear' CHECKED and put the FB14 modem.bin in the PHONE section.
  • - On reboot, you'll need to do a *228 to activate.
  • - Another reboot and "profit" :P

Speakerphone works during calls again. Also found that mic works again with bluetooth headset.

YMMV

Awesome man, nice work. Was gonna look into this tomorrow, so you saved me time, and a headache. Nice job

Share this post


Link to post
Share on other sites

Very awesome durango. It's good to know that this works now. I'm not sure if this can be made a sticky but I think it should, We should also make sure that no more people flash modems.

Share this post


Link to post
Share on other sites

CONFIRMED it WORKS!. Nice job durango

Thanks for the confirmation sickin! I tested on 2 other phones and it worked also.

Very awesome durango. It's good to know that this works now. I'm not sure if this can be made a sticky but I think it should, We should also make sure that no more people flash modems.

I did post this in the discussion forum so maybe sticky there might be worth a shot.

Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now