Sign in to follow this  

How to fix default booting to "FASTBOOT"

Recommended Posts

I recently tried to "downgrade" my phone via RSD-Lite and (of course) the flash failed.  While the phone still worked, whenever I booted it would automatically go to fastboot and show "Flash Failure".  The easy solution was to hold all the buttons to get to the bootloader and select "Boot Normal"  After seeing another member here with the same problem, I decided to find "the fix".


What's needed is a "good flash" in fastboot to remove the error.  The easiest thing to flash..... The boot logo (not to be confused with the boot animation).  I extracted the first "image" out of the boot splash (The "M" logo) and created the proper size "logo.bin" file.  Once I had this one command fixed the phone:


"fastboot flash logo logo.bin"


Yay.... Fastboot is satisfied and no longer hangs on boot.


I attached the "logo.bin" file I created.  You will need to extract from the zip as the forum wouldn't let me upload a "bin" file.

Edited by JohnB

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this