Sign in to follow this  
USCCworker

Motorola M device replacements with blue S3

Recommended Posts

Effective immediately the advance exchanges for Motorola M will be completed with the blue S3. As of last week they were going to use the Axiom. This is because of production issues from Motorola and not us cellulars choice. I have no information if this pertains to insurance claims as well.

Share this post


Link to post
Share on other sites

Wow.. Weren't they exchanging M's for s3 reception issues before?

Sent from my XT901 using Tapatalk 4 Beta

.

I believe they were. Hope that these are reception issue free. Hard to say that when talking about the S3....

Sent from my XT901 using Tapatalk 2

Share this post


Link to post
Share on other sites

I've never had reception issues on my s3 so there some good ones out there. Well reception issues that were because of the s3 anyways, only issues I've had is because of uscc spotty coverage but that's another story. My s3 and my friends m get the same signal strength.

Sent from my SCH-R530U using Tapatalk 4 Beta

Edited by andre08

Share this post


Link to post
Share on other sites

I've never had reception issues on my s3 so there some good ones out there. Well reception issues that were because of the s3 anyways, only issues I've had is because of uscc spotty coverage but that's another story. My s3 and my friends m get the same signal strength.Sent from my SCH-R530U using Tapatalk 4 Beta

You are a lucky one. My S3 and my EM like you, has similar signal strength however I have had zero dropped calls with the EM versus dropped calls with the S3.

Spotty uscc coverage isn't the issue for me.. I get better reception than Verizon in my area.

Sent from my XT901 using Tapatalk 2

Share this post


Link to post
Share on other sites

They can stuff this one you know where. The majority of S3's that are returned have been returned because of reception issues.

Many people went with the EM because of those issues with the S3's.

Share this post


Link to post
Share on other sites

I've never had reception issues on my s3 so there some good ones out there. Well reception issues that were because of the s3 anyways, only issues I've had is because of uscc spotty coverage but that's another story. My s3 and my friends m get the same signal strength.Sent from my SCH-R530U using Tapatalk 4 Beta

You are a lucky one. My S3 and my EM like you, has similar signal strength however I have had zero dropped calls with the EM versus dropped calls with the S3.

Spotty uscc coverage isn't the issue for me.. I get better reception than Verizon in my area.

Sent from my XT901 using Tapatalk 2

I was also lucky with both my mesmerize's to. I'm a firm believer in the reception issue is there but it's not as bad as people make it out to be. Placebo effect cab be amazing sometimes. My mom also has no issues.

Sent from my SCH-R530U using Tapatalk 4 Beta

Share this post


Link to post
Share on other sites

Both of our EM's have different issues that I thought about trying to exchange, but not for an S3 or Axiom. I still think there needs to be a fix for the 3g data locking issue and the shaky screen issue.

Sent from my XT901 using Tapatalk 2

Share this post


Link to post
Share on other sites

Both of our EM's have different issues that I thought about trying to exchange, but not for an S3 or Axiom. I still think there needs to be a fix for the 3g data locking issue and the shaky screen issue.

Sent from my XT901 using Tapatalk 2

Regarding the shaky screen issue. I saw a thread here regarding the S3 and asserting the developer settings so i tried it with my EM and the only time I see it now is when I unlock the phone and not all the time. I wish I could remember the thread but you can set timings for different things which helped the shakiness.

Sent from my XT901 using Tapatalk 2

Share this post


Link to post
Share on other sites

Thanks, I will check that out.  The big issue though is still the 3G issue though.  It gets old having to restart the phone when you are in the car every 30-40 miles to get data back.  And both of our M's do it, so it's gotta be a radio issue.  I also had a horrible time even getting signal on our trip to Alabama from Kansas.  In Alabama it was fine.  But Mississippi and Louisiana I had terrible service.  So much for "nationwide" coverage.

Edited by fish2222

Share this post


Link to post
Share on other sites

Thanks, I will check that out.  The big issue though is still the 3G issue though.  It gets old having to restart the phone when you are in the car every 30-40 miles to get data back.  And both of our M's do it, so it's gotta be a radio issue.  I also had a horrible time even getting signal on our trip to Alabama from Kansas.  In Alabama it was fine.  But Mississippi and Louisiana I had terrible service.  So much for "nationwide" coverage.

This has been happening more and more often to me. I didn't notice any issues until the last software update so my inclination is it's a software issue rather than radio, but maybe the radio is just going bad.

 

Have you seen/heard any others that have sent their phones in for this? Did it get fixed? Did they just do a replacement right away? I'm hesitant to send my phone in for two weeks but maybe they'll just do an exchange of some kind right away? Any suggestions on how to approach this USCCWorker?

Share this post


Link to post
Share on other sites

The first step would be to call and talk to tech. Pretty sure what they call it is resetting the data switch. I had to do this for the same problem on my original Electrify.

Share this post


Link to post
Share on other sites

The first step would be to call and talk to tech. Pretty sure what they call it is resetting the data switch. I had to do this for the same problem on my original Electrify.

Thanks. Does this require a factory reset or anything like that, or is just a software type fix that doesn't affect anything else? Basically I'm wondering if I would be able to avoid having to set my phone up all over again. Although I'd rather do that than send it off for replacement.

Share this post


Link to post
Share on other sites

I had them reset mine last Thursday or Friday, can't recall now. At first the Tier 2 tech I talked to wasn't going to do it, suggesting a device reset instead. I basically had to talk her into doing it for me just to try it before I wiped my phone and had to set it up all over again. So far no issues with not connecting to the data network after disconnecting from WiFi, and I've actually noticed improved 4G reception since. Hopefully this does serve as a permanent fix.

Share this post


Link to post
Share on other sites

I had them reset mine last Thursday or Friday, can't recall now. At first the Tier 2 tech I talked to wasn't going to do it, suggesting a device reset instead. I basically had to talk her into doing it for me just to try it before I wiped my phone and had to set it up all over again. So far no issues with not connecting to the data network after disconnecting from WiFi, and I've actually noticed improved 4G reception since. Hopefully this does serve as a permanent fix.

Can this be forwarded on to their support team as a step to take, reset their hardware FIRST

Sent from my XT901 using Tapatalk 2

Share this post


Link to post
Share on other sites

Just an update, it's been more than a week since they did the data switch reset and I've had no problems (knock on wood) with my phone not connecting to the data network after disconnecting from WiFi. I had been having that issue almost every other day leading up to that.

Share this post


Link to post
Share on other sites

I dropped my EM in a pool the other day and i have free device replacement. Went in the exchange it and they tried to give me an axiom. Needless to say i refused! Called CS and a lady there has been very helpful she has been re-processing my claim each day until an electrify m shows up. She said hopefully in the next couple days, but because i refused the axiom they did try to bribe me with an S3. Needless to say, once again, i didnt bite. We pay for the service for a comparable replacement device. Not for a high mid grade phone to replaced with basically an entry level android phone anymore. The offee for the S3 is a start but ill hold out for a few more days if it means i get my electrify M back.

Share this post


Link to post
Share on other sites

Anyone find it a little strange they're offering s3's in exchange for EM's because of a "shortage" while offering "buy one get one free" EM's in store and online? Didn't know if anyone else noticed this. I only noticed because I'm thinlong of going with the bogo deal since I just broke my s3.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this