kobester

Android lollipop coming to moto x

Recommended Posts

Let's just say we are still soaking 5.0.2 and patiently waiting for the 5.1 push. There have been bumps with the testing then fixes but in my opinion, I wish I had unlocked prior to taking the update and then wish I could have stayed with KitKat as lollipoop and moto assist just in my opinion, does not work nor does any profile app as lollipoop did away with the true full mute...

Nothing like being in a meeting and have your phone go off because moto assist and lollipoop don't play well together and don't really truly mute...

I have to manually set it to no notifications indefinitely and hope lollipoop doesn't change it on its own like my nexus tablet does...

Edited by dBuster

Share this post


Link to post
Share on other sites

After a lengthy conversation on the phone with moto on the subject it seems that we are waiting for US cellular to build/debug the rom for 1st gen moto x. Apparently it is some agreement uscc has with moto that they have control in that respect for our device.  How true that is, I do not know.

My desire for lollipop is the simply fact that it is free of a bug in the core net stack of android that effectively prevents my moto x from being used for my job when I'm out of the office. It basically prevents ipv6 from being routed of vpn tunnels the problem is what if your on the 4g network and need to access a ipv6 only resource. Simply put, you can't unless you tether from a laptop and vpn from there or use a rom that is later than 4.4.x. - https://code.google.com/p/android/issues/detail?id=62714

Edited by thomasb9511

Share this post


Link to post
Share on other sites

After a lengthy conversation on the phone with moto on the subject it seems that we are waiting for US cellular to build/debug the rom for 1st gen moto x. Apparently it is some agreement uscc has with moto that they have control in that respect for our device. How true that is, I do not know.

My desire for lollipop is the simply fact that it is free of a bug in the core net stack of android that effectively prevents my moto x from being used for my job when I'm out of the office. It basically prevents ipv6 from being routed of vpn tunnels the problem is what if your on the 4g network and need to access a ipv6 only resource. Simply put, you can't unless you tether from a laptop and vpn from there or use a rom that is later than 4.4.x. - https://code.google.com/p/android/issues/detail?id=62714

Actually the 1st gen moto x has been in soak testing for the lollipop update for a little over a month now. There are issues and we are still only testing 5.0.2 and from what it sounds like we will be bumped up to 5.1 and continue testing. There is no word from the Motorola engineers as to when we will get to the 5.1 testing.

So the hold up is not actually USCellular on this one... It is the issues that are being experienced with the android software. Some have reported issues from services getting overly hot to moto assist not working, etc.... I am not at liberty to say to much as I agreed to motorolas terms for the soak test.

If I could do it over I would unlock my bootloader just for the sake of it while on KitKat as once you go to lollipoop you can't unlock at this time. That way if you wanted to root you could. Hint hint...

I am sorry but in my opinion lollipop has some major issues that on some devices it just isn't a good idea.

In the future with your concerns I would sign up for the Motorola support forums. Then register that you would like to be a tester so you can keep up and help test, especially with your VPN concerns..

_---------------

Got the 5.1 update today. First impression, it is better than 5.0.2. Will need to put it through its paces, especially with moto assist....

Edited by dBuster

Share this post


Link to post
Share on other sites

Downloading my third update now for this soak. Will post update when done... From the blip describing it these are stability fixes??? I hope so. This update is only 70 megs roughly so I don't think it is a full android update just portions.

Hopefully something to fix the cellular standby that has been eating batteries so fast here of late... Would love to see moto assist updated as well as yesterday it wasn't announcing text messages but knew I was driving. Oh wait wonder if that soundhub app might be interfering with that. Hmmm something to look into.

Optimizing app 52 of 94 for me now...

Okay update done. Really wish I could post photos/screenshots! "Your Moto X has been updated to version 222.21.21.end.US". We shall see how today goes for use and battery life since the last update I couldn't make a full day anymore and that is with light use...

Sent from my Nexus 7 using Tapatalk without having to have a data plan

Edited by dBuster

Share this post


Link to post
Share on other sites

Been running the Brazil soak TWRP backup for a few days. Been good battery life, basically as good as before. Hopefully that's something USCC or Moto will fix. 

Share this post


Link to post
Share on other sites

Okay thought to put this back on the 1st gen thread.

So my soak is back to random reboots big time.

Also the camera seems to be borked only saving half of the pictures taken and of the half saved they turn out dark. I had one with auto hdr and auto flash and a picture taken with the auto flash, the flash worked but the phone shut down and did it a lot quicker than normal. I waited two minutes to see if it would auto start and it didn't do I powered it back on and when it was done booting it went right to the camera!

This is starting to get ridiculous now with the camera issues and random reboots.

ljohn have you had any issues like this? Fish, are you soaking with us?

Edited by dBuster

Share this post


Link to post
Share on other sites

Well today has been a flurry of activity and it seems that maybe the moto x's shipped with two different launchers? There may be an issue with the launcher is why we are having mixed issues?

Anyone want to come in here with what launcher came on your device? Either Google now launcher or one just named launcher. Mine had the just named launcher one.

Share this post


Link to post
Share on other sites

I have only heard the second gen x's got the update. We are still test driving the update and have not hit the soak stage of the process. Still experiencing issues for some and none for others. Still running into issues with profile apps not playing well with the changes in lollipoop, etc. Some users have issues with random reboots, apps the get stuck and drain the battery in minutes, to cellular standby being the major battery hog, not the screen.

Sent from my Nexus 7 using Tapatalk and not requiring a separate data plan to the tablet

Share this post


Link to post
Share on other sites

Sorry it is still in test drive mode... Trust me it is needed. Heck I just downgraded my nexus7 back to kitkat

Sent from my Nexus 7 using Tapatalk

Share this post


Link to post
Share on other sites

So they let it out without concluding the test drive or taking us from test drive to soak...

This latest release they have us on has my Bluetooth voice control broken and the camera has bugs where it will only zoom so far then it freezes the camera from inputs....

Really hope they have those things fixed for the ota to be rolling out

Sent from my Nexus 7 using Tapatalk

Share this post


Link to post
Share on other sites

I took the update on my phone - we'll see if I can live without my Xposed / Kit Kat.

 

Strange thing, I checked for the update with the wife's phone, but it said no updates needed.

Share this post


Link to post
Share on other sites

I took the update on my phone - we'll see if I can live without my Xposed / Kit Kat.

Strange thing, I checked for the update with the wife's phone, but it said no updates needed.

Xposed officially works on 5.0, and unofficially on 5.1. They're considered "alpha", but I have had zero issues whatsoever.

Share this post


Link to post
Share on other sites

I took the update on my phone - we'll see if I can live without my Xposed / Kit Kat.

Strange thing, I checked for the update with the wife's phone, but it said no updates needed.

JohnB, is your bootloader unlocked?

Since you took an ota for a release that is still in testing can you check the settings, developer settings and see if they added the unlock bootloader option to the ota for lollipoop. Right now if your bootloader isn't unlocked then you are out of luck for unlocking it with lollipoop. At least the version we are test driving.

Share this post


Link to post
Share on other sites

Bootloader was already unlocked before going in....... I checked the Developer Settings and don't see the option to allow unlocking.  Got XPosed / GravityBox working, and all is well.

Share this post


Link to post
Share on other sites

Bootloader was already unlocked before going in....... I checked the Developer Settings and don't see the option to allow unlocking. Got XPosed / GravityBox working, and all is well.

You are one of the fortunate lucky ones to have unlocked ahead of this update.

My system build is LPA23.12-21-1

the other build is 222.26.1.ghost_usc.USC.en.US USC

How does yours compare?

Share this post


Link to post
Share on other sites

I took the OTA this afternoon. Waited for it to download, then rebooted when it informed me the download was ready to install. Currently sitting at "Installing system update" for over an hour. Any idea how long a 700mb software update takes to install? It gets to a certain point (about 70% complete) and hangs.

Share this post


Link to post
Share on other sites

My system build is LPA23.12-21-1

the other build is 222.26.1.ghost_usc.USC.en.US USC

How does yours compare?

Same build here. I usually unlock within a couple of months of getting my phone.

Sent from my XT1055 using Tapatalk

Edited by JohnB

Share this post


Link to post
Share on other sites

You can disregard. Went and ate dinner. Came back and now it says Android is updating and on optimizing apps. I'll report back if there's anything weird about this update that's still in testing.

Share this post


Link to post
Share on other sites

Update installed but it was wonky and slow going between menus. Email app didn't work. Kept getting the error about Google play needing to be updated. Sim card would sometimes not be recognized. Apps would download on Google play but not fully and then would disappear on the top bar.

Finally did a factory reset and restored my apps. Pictures and stuff were backed up any way. Phone is now as speedy as before with kk and still have 5.1. 222.26.1 ghost kernel date 7/21.

I still have the black dock and top bar but not a big deal. They were transparent when I updated but before I factory reset.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now