dee3

6.0.1 Root SM-G920R4

Recommended Posts

I haven't seen anything on here or xda for a SM-G920R4, 6.0.1 Marshmallow,  US Cellular device specific root method yet,  but I rooted my Sm-g920r4 S6 tonight with stock 6.0.1 firmware very easily.  I was rooted with 5.1.1 before and flashed the 6.0. firmware this week and wanted root again.  Looked and looked and saw nothing for our specific device, US cellular Smg920r4.

I used a method from xda and it was rooted in minutes. 

It's the Sprint specific twrp I believe and flash su thru twrp.  Here's the link to the info.  

http://forum.xda-developers.com/sprint-galaxy-s6/general/guide-how-to-root-marshmallow-sm-g920p-t3338694

 

What all I did to get root on the stock 6.0.1 US cellular. 

 

*Turn on OEM unlock under developer options.  **Tap build number 7 times in Settings, About Device, to unlock developer options.**

*Download Odin if you haven't already. 

*Download the Sprint TWRP file from the link above. 

*Download the SU file from the link above to your phone. 

*Put your phone into download mode,  **hold volume down,  home key,  and power key to get into download mode.**

*Go to Odin and put the TWRP. Tar file in AP. ****UNCHECK reboot in options.****

*Flash TWRP and disconnect your phone once it is done. 

*Hold volume up,  home, and power until you see recovery is not Seandroid enforcing in small red letters on the top left,  it won't be there after first boot. 

*Go install the SU you downloaded. 

*Reboot and you're rooted.*

I didn't clean any cache or wipe anything in recovery. 

****If you don't Uncheck reboot in Odin, factory recovery will flash over TWRP,  make sure it's unchecked.****

Simple but my instructions may not be (= .. Hope this helps..  Doug..  

 

Screenshot_20160329-015912.png

Edited by dee3
More Info

Share this post


Link to post
Share on other sites

Rooted both our s6 last night with this method. I haven't had one issue on either phone. Data,  WiFi, phone quality is all good. Should go the same for you . I didn't see a root method so I decided to share what I did. Good luck and let me know how it goes. Thanks. 

Share this post


Link to post
Share on other sites

One question I have. I don't see the com port highlight when my phone is connected and in Odin.

Sent from my SM-G920R4 using Tapatalk

Share this post


Link to post
Share on other sites

You're in download mode,  the stock 6.0.1 firmware and original Samsung USB cable? Tried different ports and your USB drivers may need to be installed? I'm sure you probably know Odin but just making sure. 

Screenshot_20160329-213620.png

Screenshot_20160329-214053.png

Screenshot_20160329-214043.png

Screenshot_20160329-214025.png

Edited by dee3
.show root info

Share this post


Link to post
Share on other sites

I'll try to reinstall my drivers and see if that works. I'll let you know if that works.

Sent from my SM-G920R4 using Tapatalk

Share this post


Link to post
Share on other sites

I have xposed running and been able to do a few things thru Gravitybox module and wanam, haven't tried others yet.  Curious if you got yours rooted too Mastamindz75^^^

Screenshot_20160330-145855.png

Screenshot_20160330-145913.png

Share this post


Link to post
Share on other sites

Yes.  Before you do, have you enabled USB debugging and OEM unlock in your developer settings? And downloaded the SU file to your phone? If you have power it down.  Once off,  hold volume down,  home button,  and power button,  than once in download mode press volume up to enter it.  Volume down will reboot you. 

Screenshot_20160330-182959.png

Share this post


Link to post
Share on other sites

This thing is being stubborn. Do I leave it in MTP? Never had a phone be so stubborn to connect to Odin.

Sent from my SM-G920R4 using Tapatalk

Share this post


Link to post
Share on other sites

Also mine is in MTP under developer settings.  Again,  not sure if it needs to be.  I just know that root was easy to achieve and didn't give me any issues or issues since.  Sorry it's being difficult for you.  I'm not the best with instructions or it'd be a better diy with files linked directly and more instructions from first flashing 6.0.1. If any issues I think I can help though. 

Share this post


Link to post
Share on other sites

Thank you dee3 for giving us the solution for rooting the s6, I was just wondering how you got xposed to work,  are you on a custom rom? I thought we couldn't use it on the stock rom.  I'd love to install it but I'm afraid to try.  Would you share how you got it to work please? 

Share this post


Link to post
Share on other sites

Yes I have exposed working on the stock rom.  It needs to be flashed thru TWRP and than installed thru the apk.  Thanks for the feedback and you're welcome. 

Share this post


Link to post
Share on other sites

Awesomeness. That is what I like to hear.  Glad you got it rooted and enjoy. 

Share this post


Link to post
Share on other sites

Why is it that I have a black Facebook messenger apk that won't install? I've used it on other phones. I don't have the market Facebook apk.

Sent from my SM-G920R4 using Tapatalk

Share this post


Link to post
Share on other sites
38 minutes ago, mastamindz75 said:

Why is it that I have a black Facebook messenger apk that won't install? I've used it on other phones. I don't have the market Facebook apk.

Sent from my SM-G920R4 using Tapatalk

Does it work on any other device running Marshmallow?  Apks are not always forwards-compatible.  

Share this post


Link to post
Share on other sites

Does anyone know if this will work for the s6 edge? Thats what I have and its a pain trying to figure out ways to get a custom recovery on it.  I already have it rooted just getting the custom recovery always gives the seandroid error, it gets stuck on the boot screen with recovery is not seandroid enforcing.

Edited by jadrien1

Share this post


Link to post
Share on other sites

Anyone have issues with getting stuck at S6 splash screen and going into bootloop? Can't get past it with several different flashes.

Share this post


Link to post
Share on other sites
20 hours ago, Guest RebootMaster said:

Anyone have issues with getting stuck at S6 splash screen and going into bootloop? Can't get past it with several different flashes.

You have the correct files, right?  

Also, it can take a while to boot.  Is it actually bootlooping, or is it just taking a lot longer than normal?

Share this post


Link to post
Share on other sites
On 4/24/2016 at 2:39 PM, Guest RebootMaster said:

Anyone have issues with getting stuck at S6 splash screen and going into bootloop? Can't get past it with several different flashes.

 

 My initial boot after flashing MM took almost 2 full minutes before it started updating apps, and then it was another 10 minutes before I got to the home screen.

 

 After I rooted, it seemed to go through the entire process again.

 

Share this post


Link to post
Share on other sites

I am also getting bootloop at the splash screen. Goes to the s6 splash, hangs, restarts.

Sent from my SM-G920R4 using Tapatalk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now