JohnB

[ROM] Stock 6.0 MM / Moto X 2014 - Flashable

Recommended Posts

EDIT:  XT1093 ROM Uploaded and Ready!!!

 

Here's instructions to get Marshmallow on our "forgotten" Moto X 2014 phones.  I referenced a ROM for the Verizon XT1096 on XDA.

(ref. - http://forum.xda-developers.com/moto-x-2014/development/rom-xt1096-verizon-flashable-stock-rom-t3327345)

 

USC XT1093 specific ROM - Includes proper build.prop, TWRP 3.0, and Verizon specific files removed

 

MAIN LINK:  http://upload.teamuscellular.com/47d - USC-XT1093-STOCK-6.0.zip

Alternate Link:  https://mega.nz/#!D0I1HJjS!Mk7r-Gic8wvxBqMpBFZYXd7TF6dNXS7YK91MFVnOlOo - USC-XT1093-STOCK-6.0.zip

 

MD5SUM - ea5a700ced498d46afe60c4ebbb2d0db

 

Prerequisites:

  • Unlocked Bootloader
  • TWRP installed (I have been using the newest 3.0 version)

 

Basic Installation:

  • Backup existing ROM (including EFS partition)
  • Wipe ALL partitions including user data / sdcard (MAKE SURE YOU HAVE BACKED UP)
  • Install ROM
  • Restore EFS partition from Lollipop backup [noted in the XDA thread, but not sure if it's needed] (You did make a backup incase this doesn't work right....)
  • Flash uscc_eri.zip at the bottom of this post to fix the "Roaming Indicator Off" text in the Lockscreen / Quick Settings Pull Down
  • Boot phone
  • Setup and Enjoy

 

Optionally:

  • Root phone by flashing SuperSU-v2.65 and root-boot-6.0 (attached to this post)
  • Install Xposed (because you can...)

 

NOTES - So far, I've had working 4G / 3G and MMS / SMS.

 

UPDATE-SuperSU-v2.65-20151226141550.zip

root-boot-6.0-xt1095.zip

uscc_eri.zip

Edited by JohnB
Added uscc_eri.zip

Share this post


Link to post
Share on other sites

DUUUUUUUUDE THIS IS AWESOME THANK YOU A MILLION TIMES!

 

I'm gonna flash this as soon as I get off work... if I can wait that long.  I'll report back with how it goes.  

Share this post


Link to post
Share on other sites

So far, I've been running rooted / xposed and haven't had any issues.  The only thing I would like to "fix" yet is the "Roaming Indicator Off" text in the quick settings pull down.  I'm thinking its a fix in framework-res, but I haven't looked too far into it.

Share this post


Link to post
Share on other sites

 

1 minute ago, JohnB said:

So far, I've been running rooted / xposed and haven't had any issues.  The only thing I would like to "fix" yet is the "Roaming Indicator Off" text in the quick settings pull down.  I'm thinking its a fix in framework-res, but I haven't looked too far into it.

On Nexus devices with USCC it's in the eri.xml I believe

 

I'm downloading from Mega now, will upload to this site and change the link in OP in a bit.  DL speeds are much faster from here. 7% complete and an hour and fifteen minutes to go... ugh

Edited by BoгИX

Share this post


Link to post
Share on other sites
4 minutes ago, BoгИX said:

I'm downloading from Mega now, will upload to this site and change the link in OP in a bit.  DL speeds are much faster from here. 7% complete and an hour and fifteen minutes to go... ugh

 

That would be good.  I've tried to upload here, and it always seems to fail out (slow internet uploading on my end).

Share this post


Link to post
Share on other sites
2 hours ago, JohnB said:

 

That would be good.  I've tried to upload here, and it always seems to fail out (slow internet uploading on my end).

For some reason it won't let me edit your OP.

 

Here's the link for TUSC download:

 

USC XT1093 specific ROM - Includes proper build.prop, TWRP 3.0, and Verizon specific files removed

LINK: http://upload.teamuscellular.com/47d

Share this post


Link to post
Share on other sites
23 minutes ago, JohnB said:

OP updated with new link on the TUSC site.

 

@BoгИX - Did you have a chance to try it out?

Not yet, still at work :(

 

But I plan on installing ASAP

Share this post


Link to post
Share on other sites

Welp, I just got home. After 13 hours straight today building our website, I am in no mood to keep staring at a screen. I'm gonna have to get to this tomorrow.

:(

Share this post


Link to post
Share on other sites

I found Netflix not working right (which seems to be a common problem), but here is the solution:

  • Get Root Browser from playstore (or reboot to recovery and use the built in file manager)
  • Goto "liboemcrypto.so" file under /system/vendor/lib
  • Rename that file or delete
  • Reboot

Share this post


Link to post
Share on other sites

I believe I have the "Roaming Indicator Off" issue fixed.  I found the eri.xml fix in the Nexus forum, did a little editing to the updater-script to work on "victara" vs "shamu" and voila, the text now reads "U.S. Cellular"!!

 

The flash-able zip in located at the end of the OP.

Share this post


Link to post
Share on other sites

As I understand, the EFS partition is special partition dedicated for your phones info like radio signal info, imei and such. Since backing up and restoring was part of the instructions in the XDA thread, I've included them here.

Sent from my XT1093 using Tapatalk

Share this post


Link to post
Share on other sites
is this needed or not?

Restore EFS partition from Lollipop backup

You may not need to restore this. However, you should definitely back it up first. If you lose your imei or anything else stored in the EFS partition, you'll have to restore it.

That said, it won't hurt, and since it's quick and easy you might as well do it. If you didn't need to, oh well. If you did need to, it saves you a few minutes of your phone being broken.

Sent from my XT1575 using Tapatalk

Share this post


Link to post
Share on other sites

Ran into a screen rotation issue where it would rotate any direction it wanted, very annoying. The fix was to edit the build.prop file and add the following info

 

# Screen Roation
ro.sf.hwrotation='90'

Root is required for this edit. The build.prop file is located in the /System folder but using a build.prop editor from the play store is easiest. For some reason this line is missing so I had to add it and my screen rotation was fixed. I'm thinking this should be part of the normal build.prop file, correct me if I am wrong.

 

This also may have fixed my automatic speaker when answering or making calls, but it was not everytime. Its as if the phone did not have instructions of what to do depending on how I was holding the phone. So far so good!

Edited by KillerKellerjr

Share this post


Link to post
Share on other sites

Now if only we had a fix for the USB OTG issue. Sadly Marshmallow changed how to access a USB OTG memory stick and music apps can't access my music. With 16 GB I really need this to work. I stream too much and use my 5GB up almost before my end of period. Anyone have an easy fix for this?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now