Sign in to follow this  
na7q

LTE Roaming on T-Mobile / AT&T

Recommended Posts

I recently bought an LTE router and it is able to roam on T-Mobile and AT&T. Funny enough, it won't even connect to US Cellular. I stumped some techs with it. They also kept telling me T-Mobile isn't a roaming partner of US Cellular, but it is for sure.  AT&T though, that's a surprise though. Anyone see this happening in their phones or LTE routers? It's strange but awesome. Only downside is I can't connect to the US Cellular network. 

Its a Netgear LG2200D.

Edited by na7q

Share this post


Link to post
Share on other sites
I recently bought an LTE router and it is able to roam on T-Mobile and AT&T. Funny enough, it won't even connect to US Cellular. I stumped some techs with it. They also kept telling me T-Mobile isn't a roaming partner of US Cellular, but it is for sure.  AT&T though, that's a surprise though. Anyone see this happening in their phones or LTE routers? It's strange but awesome. Only downside is I can't connect to the US Cellular network. 
Its a Netgear LG2200D.
Have you checked if automatic roaming is enabled in the settings?

Sent from my Pixel 2 using Tapatalk

Share this post


Link to post
Share on other sites

I had disable/enabled with the same results regardless of the settings. In the end US Cellular told me that the device is no longer capable of being used on the network. Which isn't true. But they are clearly blocking them from accessing the network. They ended up tell me I needed to upgrade to new router from the store. They aren't what they used to be, very bad support and very bad technical support. I ended up with two of the devices which produced the same results. I returned them both to the seller. 

 

Immediately after, someone locally listed a NEW D-Link DWR-922 for $90, so I snatched it and activated it.

 

Works better than expected, considering I'm about 25 miles from the tower and well outside their coverage zones. Quite happy now.

It does roam on Verizon, but haven't seen T-Mobile or AT&T roaming yet.

 

And for those wondering. It does accept external SMA antennas on one or both ports. I'm using an 11DBi Log Periodic antenna with 50 feet of LMR400 (Wilson 400) coax.

Edited by na7q

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this